2

I've been having this trouble for a little while. Whenever I open a new file in spacemacs, it always opens in fundamental mode. I'm on a clean install of spacemacs on windows 10 if that matters.

To see what the content of auto-mode-alist was, I opened the scratch buffer, started an inferior emacs lisp, typed the variable name, and pressed enter. I saw a lot of output, the first of which was the association of *.el files with emacs-lisp-mode. So I tried opening a new .el file, but I still got fundamental mode. I then set auto-mode-alist to contain just the association of *.el files with emacs-lisp-mode. I opened another new file, but I got the same result.

So here is a question: is there a way to disable the auto mode choosing of emacs? Is there a setting that could possible interfere with it that I might have accidentally somehow set (but I'm on a clean spacemacs, so I don't know how it would happen)?

Note, non-spacemacs emacs works fine.

I should also note that when I open a file with windows line endings, I see lovely ^M characters at the end of all the lines. Without spacemacs, emacs picks up on the line endings and acts appropriately by hiding them.

  • 1
    What version of Spacemacs do you use ? master or develop ? – syl20bnr Apr 8 '16 at 19:27
  • @syl20bnr I just cloned the repository using the address at the top of my browser. I'm assuming that's master (sorry, I'm not very good with git). I guess I'll try using the develop branch then? – phil Apr 8 '16 at 19:53
  • 1
    I never saw this issue you should open an issue on GitHub here: github.com/syl20bnr/spacemacs/issues – syl20bnr Apr 8 '16 at 20:01
  • 1
    @syl20bnr done. – phil Apr 8 '16 at 20:16
1

Wow, this is embarrassing. I was pressing SPC f l, but apparently that is the problem. SPC f f is the correct keypress to find files. SPC f l is for opening files in fundamental mode to reduce lag caused by syntax highlighting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.