2

I am receiving the above error when trying to compile a LaTeX document in emacs 24.5, using auctex 11.89.3. Previously, I would get either "Run LaTeX again", or "Compiled successfully". This happened after I updated some packages yesterday, and I am unable to fix it. I did not pay attention to which packages were updated, and I also deleted the obsolete packages immediately, so I do not know what is causing this. Any suggestions?

2

The error you reported was probably triggered by having TeX-error-overview-open-after-TeX-run set to non-nil and TeX-debug-warnings and/or TeX-debug-bad-boxes set to nil.

This should be fixed now in development version of AUCTeX: http://git.savannah.gnu.org/gitweb/?p=auctex.git;a=commitdiff;h=88fbf8021c7da3c2bf14a646663bd0eb0ccc1448 It'll go live in next ELPA release. If you want to keep TeX-error-overview-open-after-TeX-run set to non-nil, as a workaround (but I find this a good practice in general) you can activate parsing of warnings and bad-boxes:

(setq TeX-debug-warnings t
      TeX-debug-bad-boxes t)

Background on the origin of the error: in AUCTeX 11.89.3 has been introduced the possibility to ignore certain warnings that can be considered too noisy. This is controlled by two options:

  • TeX-ignore-warnings: this controls which warnings should be ignored (usually it's a regexp)
  • TeX-suppress-ignored-warnings: this tells AUCTeX whether to actually ignore those warnings.

In this way one can interactively toggle visibility of ignored warnings with x in TeX error overview (and toggle visibility of all warnings and bad-boxes with w and b, respectively), but this also requires building of the error/warning list to be shown on-the-fly. Instead, before the fix mentioned above TeX sentinels were looking to the static full list of errors and warnings.

| improve this answer | |
  • Thanks. This does solve the problem. I had - TeX-error-overview-open-after-TeX-run non-nil and TeX-debug-warnings as well as TeX-debug-bad-boxes set to nil. I have changed the latter two to non-nil, and now the file compiles fine (though I now have to dismiss the bad-box warnings every time I compile). Hope, this is fixed in the next version. – latex_guy Apr 14 '16 at 8:50
0

I noticed the same behaviour after updating AUCTeX to version 11.89.3. As a workaround I disabled the option TeX-error-overview-open-after-TeX-run.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.