3

After I type C-x /remote.server.com TAB /, the prompt changes to spinning bar and nothing more happens. After around a minute of waiting I get the same prompt I was entering, i.e. /remote.server.com:. There’s also a buffer *tramp/scp remote.server.com opened, but it’s empty. In the Messages buffer I can see

Tramp: Opening connection for remote.server.com using scp...
Tramp: Sending command `exec ssh   -o ControlMaster=auto -o ControlPath='tramp.%C' -o ControlPersist=no -e none remote.server.com'
Tramp: Waiting for prompts from remote shell...
Timeout reached, see buffer `*tramp/scp remote.server.com*' for details
Tramp: Waiting for prompts from remote shell...failed
Tramp: Opening connection for remote.server.com using scp...failed

Autocompletion for ssh remote.server.com:/ works in a regular terminal, and shows in a couple of seconds. The server in question uses options from ~/.ssh/config, such as User, Port, HostName, IdentityFile to connect.


Debug output: http://sprunge.us/MFig

Debug output after changing remote PS1 to ‘#’: http://sprunge.us/DLcH

1
  • Same here. I read all the comments to the one answer there is currently and must say it is the same here. No output even with verbose 10 for tramp, normal connect possible in the shell without problems. But one more thing: while I see the spinning wheel, I do not see an ssh process on my machine. Yet, after I waited for a timeout, the message window contains: byte-code: [[Regexp `(^[^#$%> ]*[#$%>] *\|[a-zA-Z/~:]+[])}] ? )\'' not found in 60 secs]]. The last part of the regex is what I added to match the target host and it has worked in the past like this. – Harald May 18 '16 at 12:52
2

Pls set (setq tramp-verbose 10) and rerun the test. There will be a debug buffer, which you shall show us.

In case you don't want to show it publicly, send it to me via email.

9
  • Thanks, I’ve added the link with debug output to my post. – tijagi Apr 15 '16 at 16:19
  • There's no output at all. Strange. Pls open a local shell, and call there ssh -o ControlMaster=auto -o ControlPath='tramp.%C' -o ControlPersist=no -e none remote.server.com (replacing the real server name). What happens? – Michael Albinus Apr 15 '16 at 16:25
  • It logins and shows the prompt: remote.server.com ~ # – tijagi Apr 15 '16 at 16:30
  • This shall be visible in the debug buffer. Anyway, your prompt is not helpful for Tramp. Could you disable prompt setting at all on your remote server, temporarily? Setting $PS1 to # or something like this. – Michael Albinus Apr 15 '16 at 16:44
  • I’ve added PS1='#' to the end of /etc/bash/bashrc on the remote.server.com. The output added to the post. – tijagi Apr 15 '16 at 20:55
1

In my case this was due to rogue declaration of paths in my bash profile .bashrc:

GOROOT=/Users/jay/work 
PATH=$PATH:$GOROOT/bin 

I removed those lines from .bashrc and the problem resolved.

1
  • 1
    The only thing added to my PATH is ~/bin. Running emacs with alternated environment, where it isn’t present in the PATH, did nothing. – tijagi Jun 29 '16 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.