3

I'm running emacs 24.5.1, with the built in ido-mode. I enable (setq ido-mode-flex-matching t) and (ido-mode 1)in my startup file, and ido matching (at least the prefix and substring types of matching) work fine in the minibuffer.

But "flex matching" (as I understand it, perhaps incorrectly) should allow me to type "psw" to match a file named Pro-Something-Windows or program-swift-wings.

I've tried combinations such as psw, p-s-w, etc, but without success. Am I doing something wrong, or do I understand flex matching incorrectly? I've search the net, youtube, SO, and various IDO articles and help files, but came away with nothing (except youtube demonstrated the matching behavior that I don't get with my setup...) Thank you

3

With yet even more searching on the net and forums, I saw a single lonely reference to (setq ido-enable-flex-matching t), which is slightly different than the many references to (setq ido-mode-flex-matching t) on the net.

Sure enough, the ido-enable-flex-matching variable was the proper one to set for Emacs 24.5.1 on my machine, so now my flex matching works properly. Hopefully someone can benefit from this post. I don't know why there are so many refs to the other variable, or why it works for those other people (like the Youtube video that demonstrates both setq vars for initializing (using the variable that did not work for me), and proper flex match operation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.