0

I am using spacemacs (I don't think it should matter though) mu/mu4e and mbsync

When I use "move to folder" followed by "execute mark", I expect the "movement of message from Inbox to Archive" to be reflected on the IMAP server. But it doesn't :(

The message is "moved" from mu4e interface (I think that means mbsync locally considers the message moved) but this is not reflected on the server.

If I use (setq mu4e-change-filenames-when-moving t) in my .spacemacs there is an appearance of the movement (i.e. Message appears in the Archive folder, but it is a copy. i.e. Message is still in the Inbox and the move created a copy into the Archive folder. I definitely don't want that. So I have commented the above config setting.

I am not even sure whether this is supported.

If yes, how do I fix this ? Pointer to documentation/URL should be OK too.

Thanks.


Edit: Additional info, part of my .mbsyncrc

# Automatically create missing mailboxes, both locally and on the server
Create Both
# Save the synchronization state files in the relevant directory
SyncState *

I am not using gmail. I'm using Zoho IMAP server, if it matters.

1

I realize I am answering my own question. But leaving it here so that it is helpful for someone in the future.


It turns out it was a quirk with the IMAP server I was using. (URL in the question)

I had to turn on "Expunge immediately" option in the Server settings for the changes from mu4e to reflect on the server.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.