2

I am trying to install ranger in emacs and added this one to my .emacs file

(require 'ranger.el)
(add-to-list 'load-path "~/.emacs.d/lisp/ranger/")
(load 'ranger')

I get the following error when I open Emacs

File error: Cannot open load file, ranger.el

When I tried to compile the byte code I get the following error

Entering directory `c:/Users/nneel/.emacs.d/lisp/ranger/'
`ranger.el:84:1:Error: Cannot open load file: subr-x`

I am using GNU Emacs 24.3.1.

Now what am I supposed to do to rectify this error?

  • 1
    Report a bug in ranger.el for using subr-x (which is not available in Emacs 24.3). – wasamasa May 8 '16 at 11:14
  • @wasamasa It's not a bug, ranger requires Emacs 24.4 or newer. The OP just didn't use package.el… – lunaryorn May 8 '16 at 11:48
3

Ranger requires Emacs 24.4 or newer and does simply not support Emacs 24.3 anymore. You'll need to upgrade your Emacs version to use this extension.

Had you followed ranger's installation instructions Emacs' built-in package manager would have told you that ranger doesn't support your version of Emacs.

However, if you install packages manually it's your responsibility to check their version requirements and make sure that your Emacs version is supported.

  • Thanks. I am new to Emacs, so did not check version compatibility. Thank you again – neelabalan May 8 '16 at 12:04
  • @NeeL Why didn't you use Emacs' package manager to install? That's a lot easier than installing manually. – lunaryorn May 8 '16 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.