5

I'm using Mu4e to send emails. When I encrypt a message, it is encrypted with the receiver's public key and since I don't have the corresponding private key I can't read the message. Naturally, I want to be able to see the content of messages that I have sent to other people. However, I don't want these messages to be stored in cleartext. Some other MUAs encrypt the message two times: once for the receiver with his public key and once for storage in the sent folder with the senders public key. How can I configure Emacs to replicate this behavior?

5

The usual approach is to force encryption to happen for your own key, in addition to the recipients' (and that's only one encryption).

Depending on what you use exactly, you might want to

(setq mml2015-encrypt-to-self t)

or set

encrypt-to FOO

in your gnupg configuration, or anything similar.

This way, your messages will be stored encrypted, and you'll be asked for your passphrase whenever you want to access them.

  • oh sorry, I missed the mu4e part... I suppose only gnus uses mml2015-encrypt-to-self. There might be a mu4e specific setting, but the gnupg one should work for everyone. – Sigma Oct 16 '14 at 0:23
  • 1
    Setting mml2015-encrypt-to-self worked with Mu4e but I also had to set mml2015-sign-with-sender. The second option may work, as well, but then GPG would encrypt everything else to myself, too, and that's not always desirable. – tmalsburg Oct 17 '14 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.