1

I'm trying to run tramp in Emacs 24.3 in Ubuntu 14.04. The tramp hangs even without prompting for passcode (RSA Token). I'm able to connect to the remote host from terminal and also from M-x shell in Emacs. I set (setq tramp-verbose 10) in my .emacs file and the data present in *debug tramp/ssh host* is shown below

;; GNU Emacs: 24.3.1 Tramp: 2.2.6-24.3 -*- mode: outline; -*-
08:16:56.703770 tramp-maybe-open-connection (3) # Opening connection for ssh using scp...
08:16:56.704715 tramp-get-connection-property (7) # process-name nil
08:16:56.705305 tramp-get-connection-property (7) # process-buffer nil
08:16:56.707019 tramp-set-connection-property (7) # vector [scp nil ssh rbala@titan.ccs.ornl.gov nil]
08:16:56.707540 tramp-maybe-open-connection (6) # /bin/sh -i
08:16:56.707809 tramp-get-connection-property (7) # check-remote-echo nil
08:16:56.708036 tramp-get-connection-property (7) # check-remote-echo nil
08:16:56.708297 tramp-accept-process-output (10) # *tramp/scp ssh* run
08:16:56.708606 tramp-accept-process-output (10) # 
#$ 
08:16:56.708825 tramp-get-connection-property (7) # check-remote-echo nil
08:16:56.709043 tramp-get-connection-property (7) # check-remote-echo nil
08:16:56.709276 tramp-wait-for-regexp (6) # 
#$ 
08:16:56.709512 tramp-get-file-property (8) #  gateway nil
08:16:56.709795 tramp-set-connection-property (7) # temp-file /tmp/tramp.3232TWr
08:16:56.710451 tramp-maybe-open-connection (3) # Sending command `exec ssh   -e none ssh'
08:16:56.710721 tramp-get-connection-property (7) # process-name nil
08:16:56.710958 tramp-get-connection-property (7) # remote-echo nil
08:16:56.711172 tramp-send-command (6) # exec ssh   -e none ssh
08:16:56.711419 tramp-get-connection-property (7) # process-name nil
08:16:56.711657 tramp-get-connection-property (7) # chunksize nil
08:16:56.711886 tramp-set-connection-property (7) # last-cmd-time (22335 56 711814 288000)
08:16:56.712110 tramp-send-string (10) # exec ssh   -e none ssh
08:16:56.712320 tramp-get-connection-property (7) # process-buffer nil
08:16:56.712667 tramp-set-connection-property (7) # first-password-request t
08:16:56.713063 tramp-process-actions (3) # Waiting for prompts from remote shell
08:16:56.713389 tramp-accept-process-output (10) # *tramp/scp ssh* run
08:16:57.714433 tramp-accept-process-output (10) # 
08:16:57.714759 tramp-process-one-action (5) # Looking for regexp "\(.*ogin\( .*\)?: *\)\'" from remote shell
08:16:57.715121 tramp-get-connection-property (7) # check-remote-echo nil
08:16:57.715497 tramp-get-connection-property (7) # check-remote-echo nil

I'm able to use tramp to connect to remote hosts where ssh-keys are created. However for this particular host, I cannot use ssh-keys and I need to provide a passcode everytime I need to login My .emacs contains the following values

(require 'tramp)
;;(setq tramp-default-method "ssh")
(setq tramp-shell-prompt-pattern "^[^$>\n]*[#$%>] *\\(\[[0-9;]*[a-zA-Z] *\\)*")
(setq tramp-verbose 10)

UPDATE: Upgrading to Emacs 24.5 solved this issue.

  • That's not the whole trace buffer. Pls run the test again, from an Emacs started with emacs -Q, and with tramp-verbose set to 10. Show the whole trace buffer then. – Michael Albinus May 20 '16 at 7:10
  • the emacs -Q did not allow me to set M-x tramp-verbose. But I restarted and it produced more trace buffer, although I had to cut out a lot of it t stay within the character limit – WanderingMind May 20 '16 at 12:33
  • The relevant line is this: # exec ssh -e none ssh. It doesn't make sense, looks like a host ssh shall be connected. Which remote Tramp file name have you tried to open? – Michael Albinus May 20 '16 at 17:53
  • Nothing fancy for example it gets stuck even trying to access ~/.bashrc in the remote host – WanderingMind May 21 '16 at 2:31
1

The issue seems to be the inability of Emacs 24.3 to handle RSA token passcode request. To solve this issue I upgraded to Emacs 24.5 employing Linuxbrew as follows

brew install linuxbrew/xorg/xorg
brew install emacs --with-x11 --with-gnutls

This enabled the installation of Emacs 24.5 in the ~/.linuxbrew path which now prompts for the passcode and in turn is able to access the remote files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.