When accessing remote ftp server with tramp

C-x C-f /ftp:user@host#port/

tramp asks me for password. I also use auth-password-store to store passwords in a pass-compatibale fashion, that is, host is specified in a filename of a gpg-encrypted file containing password on its first line. However, tramp (or maybe it's AngeFtp?) keeps asking for password, even though I've created a host.gpg file in my password store.

  • I tried symlinking ftp:[email protected] to the password file.
  • I tried symlinking host#port.gpg as well as ftp:[email protected] and ftp:user@host#port.gpg
  • auth-password-store and tramp work fine together for C-x C-f /sudo::/ command, that is, it does find the appropriate file in my password-store and requests my gpg password then
  • auth-password-store works fine with symlinks to genuine password files (which is to be expected, I guess?)
  • I tried adding protocol: ftp record to password file

How do I make tramp recognise my password-store password? Should I file an issue to tramp, or maybe to AngeFtp developers?

2 Answers 2


Tramp forwards all ftp-related requests to ange-ftp. This uses the native ftp client on your local machine.

Therefore, passwords can be stored only in ~/.netrc. I doubt that this will be changed in Emacs.


I have the following two lines in my init.el:

(setq auth-sources "~/.secrets/authinfo.gpg")
(setq ange-ftp-netrc-filename auth-sources)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.