4

In my init file ~\AppData\Roaming\.emacs.d that I created using C-x C-f ~/.emacs.d/init.el RET I tried:

(require 'package) ;; You might already have this line
(add-to-list 'package-archives
             '("melpa" . "https://melpa.org/packages/"))
(when (< emacs-major-version 24)
  ;; For important compatibility libraries like cl-lib
  (add-to-list 'package-archives '("gnu" . "http://elpa.gnu.org/packages/")))
(package-initialize) ;; You might already have this line

and

(setq package-archives '(("gnu" . "https://elpa.gnu.org/packages/")
                         ("marmalade" . "https://marmalade-repo.org/packages/")
                         ("melpa" . "https://melpa.org/packages/")))

and

(add-to-list 'package-archives '("marmalade" . "https://marmalade-repo.org/packages/"))
(add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/"))
(add-to-list 'package-archives '("org" . "http://orgmode.org/elpa/") t) ; Org-mode's repository

using both https:// and http:// since the Melpa website states there are issues with windows and https

Each time I have edited and saved the file and afterwards (re-)started Emacs. Still after C-x list-packages RET I seem to get the ELPA list only.

I'd really appreciate some help, because I have no idea what I'm doing wrong.

4

this video gave me the clue to solve my problem:

M-x customize-group RET package RET

Expand "Package Archives" then INS

Fill in:

Archive Name: melpa

and URL or directory name: http://melpa.org/packages/

Apply and Save

(https didn't work)

1

I would recommend for Windows (as long as you have 64-bit) downloading the emacs-w64 distribution as it comes bundled with all of the extra libraries you need to make things like ssl and images work. Failing that, you can download the latest in gnutls here and place the contents of the /bin directory in the same folder as emacs.exe.

  • Sounds useful, but I don't think it speaks to the question. – Drew May 24 '16 at 0:59
  • Perhaps, but I haven't had any HTTPS issues on Windows since downloading the emacs-w64 builds. – Ryan May 24 '16 at 4:20
  • It wasn't the https issues, it was the fact that emacs wasn't even trying to connect. – quazoosl May 24 '16 at 11:00
0

Since you mentioned you can accept http connection without security concern,

(setq package-archives
        '(("gnu" . "http://elpa.gnu.org/packages/")
          ("melpa-stable" . "http://stable.melpa.org/packages/")
          ("org" . "http://orgmode.org/elpa/")))
  • As I stated in my original post, I tried adding that block of code using both http and https – quazoosl May 24 '16 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.