1

Running windows 8.1, package intallation went fine.

Enabling with M-x ergoemacs-mode works like a charm, but doing this every time I start up Emacs gets quite tiresome.

adding

(setq ergoemacs-theme nil) ;; Uses Standard Ergoemacs keyboard theme
(setq ergoemacs-keyboard-layout "us") ;; Assumes QWERTY keyboard layout
(ergoemacs-mode 1)

to ~/.emacs as advised here gets me the following error:

Warning (initialization): An error occurred while loading `c:/Users/UserName/AppData/Roaming/.emacs':

Symbol's function definition is void: ergoemacs-mode

To ensure normal operation, you should investigate and remove the
cause of the error in your initialization file.  Start Emacs with
the `--debug-init' option to view a complete error backtrace.

I don't have a clue about how to do this debug mode properly (get No Match in return), but in the manual I found how to evaluate each expression. using C-x C-e Evaluating first two of the added lines give me nil and "us", and evaluating the last line enables ergoemacs-mode.

in my ~/.emacs I also found this block of code:

 '(ergoemacs-ctl-c-or-ctl-x-delay 0.2)
 '(ergoemacs-handle-ctl-c-or-ctl-x (quote both))
 '(ergoemacs-ini-mode t)
 '(ergoemacs-keyboard-layout "us")
 '(ergoemacs-mode nil)
 '(ergoemacs-smart-paste nil)
 '(ergoemacs-theme "standard")
 '(ergoemacs-theme-options nil)
 '(ergoemacs-use-menus t)

Neither changing '(ergoemacs-mode nil) to (ergoemacs-mode 1), removing that line OR changing '(ergoemacs-mode nil) to (ergoemacs-mode 1) and removing the other 3 lines works.

Please advise.

  • Welcome to emacs.stackexchange! Where is your (package-initialize) or (require 'ergoemacs-mode) statements to load the library at issue before you start trying to use something within the library? Did you follow the quick-start guide?: ergoemacs.github.io – lawlist May 24 '16 at 21:24
  • I didn't know I needed one (I'm quite new to Emacs and I don't dare call myself a programmer yet) – quazoosl May 24 '16 at 21:30
  • 1
    I gave you a plus+1 to your reputation because you documented the issue sufficiently well enough for everyone to see what may be the problem. I think everyone who uses Emacs has had to figure out how to call package-initialize and/or require at one time or another -- it is part of the ritual baptism when joining the Emacs cult following. – lawlist May 24 '16 at 21:32
  • Thank you, I overlooked that. I still can't get it to work though... ' Warning (initialization): An error occurred while loading `c:/Users/Jan-Rienk/AppData/Roaming/.emacs': Wrong type argument: listp, t' – quazoosl May 24 '16 at 21:52
  • You may find it helpful to add (setq debug-on-error t) to the top of your .emacs file, save, and restart Emacs. It may help you see more details regarding where the problem is. I keep debugging enabled all the time, but feel free to remove it or comment it out once you track down the problem. – lawlist May 24 '16 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.