0

Am new to Emacs and am using Spacemacs, Emacs mode. After following the basic Emacs tutorial, I create an html file and try to use emacs for code editing. So I installed the html layer, after activating emmet-mode, it still stuck at web-mode. And I got any autocompletion. Like typing :.my-class + TAB don't generate any code.

enter image description here

1

You need to enable/configure auto-completion mode perhaps?

Spacemacs Autocompletion

4
  • I just check this but auto-completion is already enabled :/
    – Asme Just
    May 25 '16 at 15:24
  • 2
    web-mode should aromatically enable emmet, if I am not mistaken. At least I did not add anything special, aside from my emmet configuration. Try this: restart emacs. M-m or space depending on edit mode, then f -> J, then enter HTML as extension. Then try from scratch.
    – MaDhAt2r
    May 25 '16 at 18:28
  • Also, what engine are you using for autocomplete, company (suggested) or auto-complete? And did you enable it globally? (global-company-mode) in the dotspacemacs/user-config?
    – MaDhAt2r
    May 25 '16 at 18:32
  • I found out that i needed to hit Ctrl-j to make it works. :)
    – Asme Just
    May 31 '16 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.