4

After I did an overhaul of my .emacs file yesterday (adding/removing packages, organizing, etc.), I'm left with an annoying screen flicker. It happens when I move the cursor to the edge of the buffer and keep trying to move it in that direction.

For example, below is a video in which I start up Emacs, navigate my cursor to the top of the new scratch buffer (C-p) and then continue pressing C-p. It does the same thing if I do C-g (cancel command) when there are no commands to be cancelled as well as a number of other commands which don't move the cursor.

Before adding a list of packages / settings from my .emacs file into this post, I thought I'd ask if anyone had experienced similar problems and if there were any quick changes to settings that did the trick.

enter image description here

5

It looks like visible-bell mode is enabled. This means that whenever an Emacs command rings a bell (i.e. fails in some way), it will try to flash the screen.

You should be able to turn it off with (setq visible-bell nil).

Flickering is annoying, but the bell gives you useful information so I wouldn't want to suppress it completely. You can customize exactly what happens with the bell by setting ring-bell-function, which will run an arbitrary Elisp function each time.

It's also possible that Emacs is using an audio beep that gets translated to flickering by your terminal. This is likely the case if visible-bell is already nil. If so, you could try setting visible-bell to t, which will let Emacs handle the flashing itself—that could be less intrusive. Or you could just customize it however you like as described above.

  • 1
    (setq ring-bell-function #'ignore) – Jordon Biondo Oct 16 '14 at 18:02
0

If you're running sublimity-mode, don't. It does this type of stuff when run in -nw.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.