2

Often I type a command like C-x C-f and then want to cancel it by pressing C-g. In normal emacs this was never a problem, but with helm I get a big minibuffer that says Quit and then shows some weird stuff. Pressing C-g more times doesn't fix anything. (If it matters, I'm using spacemacs in holy-mode, but I'm convinced this is a helm-specific issue).

Demo

After pressing C-x C-f: enter image description here

After pressing C-g to cancel, the minibuf says Quit at the top and then displays: enter image description here

If I press C-g more times I just get more [No match]s at the bottom. The only solution is to press RET until it opens some random file, which is of course undesirable behavior. This happens for all commands, not just C-x C-f.

  • Consider reporting a bug to the maintainers of the libraries. But just as hoping for hope here, it will help if you provide a step-by-step recipe to reproduce the problem(s), starting from emacs -Q (no init file). – Drew May 28 '16 at 21:36
  • The attached screen shots doesn't seems related to helm. – xuchunyang May 29 '16 at 10:43
  • @Drew Instead of emacs -Q, consider using the provided emacs-helm.sh script, which sets up a minimal Emacs with vanilla Helm options. – Tianxiang Xiong Jun 19 '16 at 5:23
  • @tianxiangxiong I've found that C-] works. – Elliot Gorokhovsky Jun 19 '16 at 5:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.