3

I have Installed from Melpa ob-ipython on Ubuntu Xenial with Emacs 24. If I try to evaluate a source code like:

#+BEGIN_SRC ipython :session
%matplotlib inline
importmatplotlib.pyplot as plt
inport numpy as np
#+END_SRC

I get the following error:

No org-babel-execute function for ipython

What can I do to solve this problem?

2

You need to update org-babel-load-languages. Try this:

(org-babel-do-load-languages 'org-babel-load-languages 
                             '((emacs-lisp . t)
                               (ipython . t)))

This is described in the Org Manual

  • I got an initialization error while loading .emacs: File error: Cannot open load file, no such file or directory, ob-ipython – falematte May 31 '16 at 20:50
  • Can you post a minimum working example of an init file that recreates your problem? – scbagley Jun 2 '16 at 1:12
  • It looks like adding (package-initialize) (require 'ob-ipython) solved the problem! – falematte Jun 2 '16 at 9:51
2

It looks like adding (package-initialize) (require 'ob-ipython) to my .emacs solved the problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.