10

When I have a buffer with unsaved changes, magit asks for each and every action to save that changes.

I didn't save that changes on purpose, so is there a way to disable this behaviour? My Magit should simply ignore unsaved changes.

11

Magit has a variable called magit-save-repository-buffers that is by default set to t. Try setting it to nil

  • Works like a charm, thank you very much! – ckruse Jun 3 '16 at 8:13
2

Here is the documentation for the magit-save-repository-buffers variable, which describes the behavior for values t, nil, and 'dontask.

Documentation: Whether to save file-visiting buffers when appropriate.

If this is non-nil then all modified file-visiting buffers belonging to the current repository may be saved before running commands, before creating new Magit buffers, and before explicitly refreshing such buffers. If this is `dontask' then this is done without user intervention, if it is t then the user has to confirm each save. `dontask' is the recommended setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.