2

using spacemacs in java mode, moving the mouse over an email address displays in the modeline the text mouse-1, C-c RET: mail this address. And if I click on it, a blank email sending form is opened in emacs (strangely enough that doesn't happen in haskell mode or fundamental).

My issue is that while I don't use the mouse much when using emacs, I often use it to focus the emacs window. And if there's somehow an email address exactly where I click, I open that email compose buffer, which is never what I want, because (at this point) I don't use emacs for email sending.

How can I disable that "click to compose an email" feature?

0

I got the answer on #emacs on freenode. The suggestion was that presumably goto-address-mode should be related to the issue. It seems it's actually turned off in java-mode in my setup, however turning that minor mode off does fix the issue for me.

So the workaround is to put this in the emacs startup script (.spacemacs under spacemacs):

(add-hook 'java-mode-hook (lambda () (goto-address-mode -1)))

That does fix the issue for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.