0

Certain org-mode buffers seem to write to file automatically when left idle even for a second. I've tried disabling a few minor modes but to no avail. It makes it all the more difficult to debug this since it only happens with a few org-mode buffers.

Version:

GNU Emacs 24.5.1 (x86_64-apple-darwin14.1.0, Carbon Version 157 AppKit 1344.72)

Enabled Minor modes in the buffer:

Async-Bytecomp-Package Auto-Composition Auto-Fill
Auto-Revert Blink-Cursor Company Delete-Selection Diff-Auto-Refine Disable-Mouse
File-Name-Shadow Flx-Ido Font-Lock Global-Auto-Revert Global-Company
Global-Font-Lock Global-Git-Commit Global-Prettify-Symbols Helm Ido-Everywhere
Ido-Vertical Line-Number Mac-Mouse-Wheel Magit-Auto-Revert Org-Bullets
Org-Indent Override-Global Recentf Shell-Dirtrack Show-Paren Smartparens
Smartparens-Global Tooltip Transient-Mark Window-Numbering Yas Yas-Global

My configuration is located at https://github.com/kirang89/.emacs.d.

I'd be really awesome if someone could help me out on this one. Thanks!

  • 2
    I don't have an answer, but it may be worthwhile to check the timers to see if you can get the name of a function that looks suspicious. M-x describe-variable RET timer-idle-list RET and M-x describe-variable RET timer-list RET. Be sure to check both variables. – lawlist Jun 4 '16 at 7:11
  • Ah, that was the clue I was looking for. I found a deft-auto-save function that runs instantly when idle. Delaying the interval did the trick. Thanks! – Kiran Jun 4 '16 at 9:24
2

According to the suggestion by @lawlist, I ran M-x describe-variable RET timer-idle-list RET to find out that a function named deft-auto-save ran instantly after Emacs went idle. Setting

(setq deft-auto-save-interval 20)

did the trick. Apparently, this interval matters only for org files that were launched by deft. This explains why the autosaving behaviour wasn't consistent across all org-mode buffers that I dealt with.

  • Yes, auto-saving is a feature of deft and isn't really related to org mode -- I think deft uses text mode by default. – glucas Jun 4 '16 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.