4

I have exactly this org file:

* TODO EAT                                 :home:
** make 
** me
** a
** sandwich
* TODO CODE                                :home:
** make
** me
** code
* TODO SLEEP                                :bed:
** dream with
** dragons
* TODO REPEAT                              :universe:

I want to filter it by tags, so I:

  1. M-x + org-agenda
  2. m
  3. home

Then nothing. As if there wasn't any item tagged with home. Although, as you can see, there is.

I'm I doing something wrong? I can not filter by anything, even the "All TODO's" option displays no items at all.

I really want to get into org-mode. Please help me :(

5

You are seeing that behavior because that org file needs to be in your agenda (org-agenda-files) if you do an unrestricted match for the agenda. You can specify what files (and directories) to include in your agenda by setting it to a list:

(setq org-agenda-files
  '("~/path/to/this.org"
    "~/path/to/another/file.org"
    "~/path/to/org-directory/"))

Alternatively you can use org-agenda without including files in your agenda by using the dispatcher to restrict the search to the current buffer or subtree (the current file needn't be in org-agenda-files). Type < when you see the dispatcher to cycle among 'unrestricted', 'buffer', and 'subtree'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.