0

Is there a way to make pdf-export of files named in russian?

I use xelatex which is set up like:

(setq org-latex-pdf-process
      '("xelatex -shell-escape -interaction nonstopmode -output-directory %o %f"
        "xelatex -shell-escape -interaction nonstopmode -output-directory %o %f"
        "xelatex -shell-escape -interaction nonstopmode -output-directory %o %f"))

latin named files are ok to be exported, but if I name it Документ.org then there is an error:

*messages*

org-latex-compile: PDF file ./Документ.pdf wasn't produced

*Org PDF LaTeX Output*

This is XeTeX, Version 3.14159265-2.6-0.99996 (TeX Live 2016/W32TeX) (preloaded format=xelatex)
 \write18 enabled.
entering extended mode
! I can't find file `'"c:/Users/user/org/work/Документ.tex"''.
<*> .../work/Докуметн.tex"'

(Press Enter to retry, or Control-Z to exit)
Please type another input file name
! Emergency stop.
<*> .../work/Документ.tex"'

No pages of output.
Transcript written on .//texput.log.
  • It's a latex thing. – rasmus Jun 9 '16 at 16:55
  • I tried the same thing on OSX -- and it works. So it is windows make the difference. I guess I have to use ascii then. – Maxim Kim Jun 9 '16 at 17:14
  • You are right. Thanks for reporting that. Your filename also works on my GNU/Linux. I think windows might still be running in latin-1... – rasmus Jun 11 '16 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.