No *curses applications (like top, htop, Linux kernel's make menuconfig and others) will work under emacs' different terms. However, the only one which seems to work is git add -i

It behaves the same under term, multi-term and ansi-term: output a lot of messy garbage. It does the same when not splitting frames and I reproduced this behavior without any configuration (moved .emacs and .emacs.d somewhere else).

I included a screenshot of when I tried a make menuconfig in Linux kernel's base directory.

I am running GNU Emacs 24.5.1 (x86_64-pc-linux-gnu, GTK+ Version 3.18.9) of 2016-04-17 on lgw01-04, modified by Debian in GUI on Ubuntu 16.04.

Is there a way of fixing this ? Is it just an isolated bug or related to emacs in general ?

enter image description here

  • FYI I have no issues running top and htop under ansi-term in Emacs 24.5. Possibly your issues are on account of missing eterm-color terminfo? I believe apt-get install ncurses-term on Debian systems should install this for you; or you can copy (or symlink) the eterm-color and eterm-color.ti files from the /usr/share/emacs/xx.x/etc/e directory to a ~/.terminfo/e/ directory, or system-wide at /usr/share/terminfo/e/.
    – phils
    Jun 10, 2016 at 0:48
  • I installed ncurses-term with no results. Then I tried to move /usr/share/emacs/24.5/etc/e/eterm-color* to /usr/share/terminfo/e/ without success. Also tried to move them to ~/.terminfo/e/ without a change. Also removed original eterm-color from /usr/share/terminfo/e/ still without a change. Also tried to do the opposite and moved /usr/share/terminfo/e/eterm-color to /usr/share/emacs/xx.x/etc/e/ but that didn't work. Do I need to reboot, login/logout, use another command to refresh some cache or activate these configs ?
    – deb0ch
    Jun 10, 2016 at 8:27
  • I don't think so. You could try it, but I'm guessing this wasn't actually the source of the problem (but nevertheless a good thing to have in place, and to keep in mind in general for any remote hosts you connect to).
    – phils
    Jun 10, 2016 at 9:19

1 Answer 1


Reddit just had a discussion on terminals. Try this?

(setq eshell-visual-commands 
      (cons eshell-visual-commands '("el" "elinks" "htop" "less" "ssh" "tmux" "top" "mbsync" "docker" "docker-compose"))


  • this only affects eshell, which is is not a terminal at all Jun 16, 2016 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.