The functions org-lookup-first, org-lookup-last, and org-lookup-all do not seem to be available to me. These functions are documented at the following link: Lookup Functions.

I can't look them up in the help system, and they don't work when I try to use the functions replicating tutorials. It seems like something is preventing these functions from being available. I don't think that there is anything in my config that would be doing this though. Does anyone have any ideas why this might be happening?

2 Answers 2


Your org is too old. These functions were added to pre8 version of org. Upgrade your org package to version 8 and org-table should be automatically included.


You need to load the org-table library. You can customize the org-modules variable to include it.

  • They still are not available after doing this.
    – Chris
    Commented Oct 20, 2014 at 22:17
  • You need to reload org to get it to load the org-table library via org-modules. If they are still not available perhaps your org-mode version is too old. Commented Oct 20, 2014 at 22:26
  • Also - these are elisp functions, not formulas for use in the spreadsheet. Commented Oct 20, 2014 at 23:24
  • Still not available after requiring org-table. I don't think version is the issue as I do see in the code the macro that is supposed to define the functions. For what it's worth, Org is version 7.9.3f. Emacs version is 24.3.1.
    – Chris
    Commented Oct 21, 2014 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.