4

Using a simple keyboard macro, I copied the Font Awesome Cheat Sheet into an org table. However, I experience some weird inconsistencies when it comes to the formatting - see the picture below:

org table formatting issue

Any ideas how that happens and how to fix it?

  • If you put the cursor in the table and TAB, the columns should automatically align. That's the default behavior for org-mode. – Emacs User Jun 11 '16 at 15:21
  • @EmacsUser I did that. The above is the alignment I got. (Prior to that, it looked way worse.) – Stefan Mesken Jun 11 '16 at 15:29
  • In case anyone wants to try it themselves, here is a link to the org file on Google Drives. – Stefan Mesken Jun 11 '16 at 15:36
  • 1
    @iluvatar Are all symbols displayed correctly? (I ask, because it's certainly aligned if you don't have awesome fonts installed.) – Stefan Mesken Jun 11 '16 at 19:08
  • 1
    What is interesting is that the table is aligned when running emacs on a terminal (no gui) but not aligned when running on the gui. I do not know why. – iluvatar Jun 13 '16 at 18:32
3

Org-mode table formatting assumes a true fixed-width font.

Many Unicode glyphs have odd sizes; check for example fa-chevron-left by setting the cursor there and comparing its size to other standard characters.

I personally don't know of a fixed-width font across all characters.

  • 1
    That's what I expected. Is there a workaround? – Stefan Mesken Jun 11 '16 at 19:08
  • On my Linux system I tried both the Ubuntu Mono font and the Fira Mono font and in both cases only the final column of |s looks ragged. The vertical bars between the columns are ok (although the vertical bars don't align with the horizontal top line. However, these fonts definitely don't cover all symbols. – ph0t0nix Jun 12 '16 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.