4

I've been working hard to get emacs and org-mode working inside of my tmux workflow. And i've got a pretty decent setup. :)

I installed org-bullets to get utf8 bullets, it worked. But even if I set into my emacs init file that I want the clean view it show the previous stars for every item. Also tried with the in-file solution but nothing.

Here is specifically what I tried

on my init:

;; Hide leading stars
(setq org-startup-indented t
      org-hide-leading-stars t)

On my org file:

#+STARTUP: indent

It works perfectly on the windowed environment, buy inside my terminal stars didn't disappear

4

The variable org-hide-leading-stars just uses the face org-hide behind the scenes.

Pressing C-hv (to get help on a variable) and then typing org-hide-leading-starsEnter will show you what you need to do.

The documentation for the variable says

Non-nil means hide the first N-1 stars in a headline. This works by using the face org-hide for these stars. This face is white for a light background, and black for a dark background. You may have to customize the face org-hide to make this work.

Emphasis mine.

You can customize the face by typing M-xcustomize-faceEnterorg-hideEnter

Set the foreground color of the face to the colour of your background in tmux.

  • This should be the beginning of the answer. Thank you so much. Though, even after customizing the org-hide face, it doesn't work in -nw mode, just in the gui. :( – Alevardi Jun 13 '16 at 17:04
  • 2
    Some follow up information for Mac+iTerm users: if you can still see the stars, even after following the advice of Gambo, then: 1. open your iterm preferences 2. navigate to the colour preferences for your preferred profile 3. drag the minimum contrast slider all the way to the left – Sam Oct 16 '16 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.