I'm new to emacs (spacemacs). I've set up the col-highlight package in my .spacemacs like so:

(column-highlight-mode 1)
(set-face-attribute 'col-highlight nil :inherit 'hl-line :background)

in order to pick up the background of the current line for the current column.

How can I set the same background for the column in long wrapped lines? The background of the current column of wrapped lines does not match and is an annoying contrasting white.

EDIT: should have mentioned that this is emacs/spacemacs in terminal mode. I now think this related to my .Xresources file.

EDIT2: see - https://github.com/DougDavenport/spacemacs for an image of the issue and my .Xresources file

  • 2
    Maybe show a screenshot of what you mean about what it does for wrapped lines? – Drew Jun 18 '16 at 13:18
  • Also, there is no publicly available library for column highlight when word-wrap is enabled. Please clarify whether you are using visual-line-mode. The publicly available libraries for column highlight work okay in the majority of circumstances when not using visual-line-mode. – lawlist Jun 18 '16 at 16:45
  • @Drew please see edits to original question. This question is related to terminal spacemacs. When getting a screenshot as suggested, I realized that the issue was probably related to my .Xresources file (see link above). I was outside when answering your questions and using the solarized light option from my .Xresources and relaized there was not an issue. The linked screenshot shows the solarized dark option. I'm working on trying to understand the issue. Any suggestions are appreciated. My environment is Arch linux, i3wm, URxvt, and tmux. – Douglas Davenport Jun 18 '16 at 18:04
  • @lawlist please see edits and previous comment – Douglas Davenport Jun 18 '16 at 18:04
  • @lawlist visual-line-mode is disabled – Douglas Davenport Jun 18 '16 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.