0

I am trying to install elpy on my machine (ubuntu 14.04), but getting the following issue. any comment, hint?

Thanks.

Requirement already satisfied (use --upgrade to upgrade): elpy in ./work/software/anaconda3/lib/python3.5/site-packages
Requirement already satisfied (use --upgrade to upgrade): importmagic in ./work/software/anaconda3/lib/python3.5/site-packages (from elpy)
Requirement already satisfied (use --upgrade to upgrade): flake8>=2.0 in ./work/software/anaconda3/lib/python3.5/site-packages (from elpy)
Requirement already satisfied (use --upgrade to upgrade): setuptools>=0.6b1 in ./work/software/anaconda3/lib/python3.5/site-packages/setuptools-20.3-py3.5.egg (from importmagic->elpy)
Requirement already satisfied (use --upgrade to upgrade): pyflakes!=1.2.0,!=1.2.1,!=1.2.2,<1.3,>=0.8.1 in ./work/software/anaconda3/lib/python3.5/site-packages (from flake8>=2.0->elpy)
Requirement already satisfied (use --upgrade to upgrade): pycodestyle<2.1,>=2.0 in ./work/software/anaconda3/lib/python3.5/site-packages (from flake8>=2.0->elpy)
Requirement already satisfied (use --upgrade to upgrade): mccabe<0.6,>=0.2.1 in ./work/software/anaconda3/lib/python3.5/site-packages (from flake8>=2.0->elpy)
  • 2
    As always, please provide a step-by-step recipe to reproduce the problem, starting with emacs -Q (no init file). Most of us are not mindreaders (though you might luck out by finding one here who recognizes your problem from such a rudimentary description). – Drew Jun 23 '16 at 20:56
1

You need to install it in emacs as well.

M-x <RET> package-install <RET> elpy <RET>

Then in your init.el add (elpy-enable)

Now when you open python files you should see the elpy minor mode enabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.