When I run list-colors-display I get the following:

enter image description here

which I think is a very small subset of colors that my Emacs supports, isn't it?

For example, I know Emacs supports other colors (gray20, blue15, etc). Why am I not seeing them as a result of the list-colors-display command?

How can I see the full list?

In case it matters, my version is:

"GNU Emacs (x86_64-apple-darwin15.5.0, NS appkit-1404.47 Version 10.11.5 (Build 15F34)) of 2016-06-20"

If I evaluate:


I get:

("alternateSelectedControlColor" "alternateSelectedControlTextColor" "controlBackgroundColor" "controlColor" "controlDarkShadowColor" "controlHighlightColor" "controlLightHighlightColor" "controlShadowColor" "controlTextColor" "disabledControlTextColor" "gridColor" "headerColor" ...)
  • 1
    Maybe version 25 does something different. When I run ESC-x list-colors-display on my Mac (Emacs 24.4 app), I see the same colors and layout that you post in your posting. BUT... the part that you are showing is at the very bottom of the list of colors that I see. It's as if your window scrolled to the bottom of the color list when it ran the command.
    – Kevin
    Jun 26, 2016 at 18:30
  • Exactly what @Kevin says, and looking at the code of list-colors-display, it would appear that the original poster is getting nil for (defined-colors). I would suggest that the original poster evaluate (message "%s" (defined-colors)) and let us know what the results are. I would also suggest downloading a fresh version of a nightly build from Emacs for OSX and see if it works as expected out-of-the-box. emacsformacosx.com
    – lawlist
    Jun 26, 2016 at 19:09
  • 2
    Doing some back-tracing of the code, I see that during the build process, the function (ns-list-colors) is used to set up the variable x-colors and the original poster is suffering from a partial-list -- i.e., missing "LightGreen" "light green" "DarkRed" "dark red" . . . "GhostWhite" "ghost white" "snow" which precedes "alternateSelectedControlColor" "alternateSelectedControlTextColor" Again, I strongly suspect the build itself -- something is broken -- try a new version from the link above. It can be download and tested in about 3 minutes.
    – lawlist
    Jun 26, 2016 at 19:33
  • The colors you are seeing what you would see in the OS X Color Chooser, clicked the third icon from the left, and selected "Developer". I have Emacs 24.5.1 and have the same problem. This was not problem in previous releases -- I got the full Emacs color list. i was running Emacs installed from MacPorts. Since its version was the same as the one advertised at the above link I didn't see any point in downloading it. Eventually I stopped being stubborn, downloaded it, and the problem is gone. Not good to have different behavior in 2 implementations of an application with the same version. Aug 20, 2016 at 13:48
  • This appears to be exclusively a problem with the emacs-app port in MacPorts. If you compile Emacs yourself, you won't see this issue. The issue is exactly as @lawlist described. This problem is still an issue with emacs-app 26.1 from MacPorts.
    – Y.H Wong
    Jun 2, 2018 at 18:54

1 Answer 1


As @lawlist and @kevin commented, this was a problem with the nightly snapshot that I used. I re-installed Emacs:

brew install emacs --devel  --with-cocoa --with-gnutls  --with-librsvg --with-imagemagick

and the problem went away.

  • Error: invalid option: --devel
    – alper
    May 2, 2023 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.