5

I'm struggling to run fzf in emacs but cannot figure out whats my problem. When I run fzf - and start typing - text gets mess up, similar to this:

enter image description here I tried run fzf in term, eshell, ansi-term, multi-term modes, with and without --color=no option, its all the same. Does anyone knows what is my problem could be? Thx.

3
  • eshell doesn't support interactive programs, see this. But I tried ansi-term calling fzf with keybindings (CRTL-T, CTRL-R, ALT-C) and it just works. It maybe related to your .emacs.d
    – Choma
    Commented Nov 8, 2016 at 23:12
  • @Choma what variable did you set to not use ESHELL and ansi-term instead? Commented Jul 10, 2017 at 11:38
  • 1
    @DarrylHebbes, I just did M-x ansi-term, it will ask you for a program to run, with /bin/bash as default
    – Choma
    Commented Jul 11, 2017 at 14:10

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.