1

I am running Emacs version 25.0.92.1, Spacemacs 0.105.x, Windows 7. In my .spacemacs, in dotspacemacs/user-config I have:

;; Org
;; Org-pomodoro
(setq org-pomodoro-length 25)
(setq org-pomodoro-short-break-length 5)
(setq org-pomodoro-long-break-length 15)
(setq org-pomodoro-play-sounds 1)

In .emacs.d\elpa\org-pomodoro-20151217.553\resources I have bell.wav, bell_multiple.wav and tick.wav. When running a pomodoro it doesn't play any sounds. What do I need to change to get sounds working and what do I need to change to use my own sounds?

  • I don't think this has anything to do with Spacemacs. Spacemacs is only a config. By adding Spacemacs to the question and tag, you are limiting the number of people who would even read the question. As a Spacemacs user, if you know where to put the config stuff, this question boils down to a more general question of why this is not working and what needs to be done to fix it. "Where" to put the fix could be different for each user. – Kaushal Modi Aug 30 '16 at 9:50
2

It seems like org-pomodoro potentially uses sound-wav to play sounds.

Install it, along with powershell:

M-x package-install [RET] sound-wav [RET]
M-x package-install [RET] poweshell [RET]

Good luck!

1

Run M-x customize-group and you should see a group called org-pomodoro. All related options, including the sound, should be there.

  • Thanks for the suggestion. customize-group does not have org-pomodoro in it, though I am able to run a pomodoro. – user619882 Jul 4 '16 at 20:32
  • Worked for me!! – basilikode Dec 8 '17 at 14:02
0

Spacemacs' org layer is missing the sound-wav package. I just had to add it to my .spacemacs' additional packages and restart Emacs:

dotspacemacs-additional-packages '(sound-wav)

To hear the ticking sound, enable Org Pomodoro Ticking Sound P in customize-group [RET] org-pomodoro [RET].

For vanilla Emacs, you might have to install sound-wav (and powershell if you're in Winbugs):

M-x package-install [RET] sound-wav [RET]
M-x package-install [RET] powershell [RET]

And add to your .emacs:

(require 'sound-wav)

You can test sound-wav with

(sound-wav-play "/path/to/audio.wav")

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.