3

Sometimes emacs takes a very long time (+ 30 seconds) to read from or save to the system (Linux) clipboard. The entire emacs session hangs while it does this and I can't cancel it with C-g or ESC ESC ESC or anything. This seems to happen at random, but whenever it does happen, it tends to happen more frequently until I restart emacs.

What could be causing this behavior? Where should I start? I haven't changed the default values of x-select-enable-clipboard (t) or any other clipboard-related variables (to my knowledge)...

  • If you can repro this starting with emacs -Q then please file a bug report for it: M-x report-emacs-bug. If not, recursively bisect your init file to find the code that manifests this. – Drew Jun 29 '16 at 16:56
  • I've experienced this as well, but with weeks or months passing between cases. I can't help, sorry, but it's certainly odd and annoying when it occurs. – phils Jun 30 '16 at 10:12
  • Yeah, it seems to happen at random and the intervals between cases can be hours or weeks. I've got no idea how to fix it, and bisecting the init file will be difficult because I don't know if I "solved" the problem or if it's just not getting triggered... – Alex Jun 30 '16 at 12:45
  • At risk of a "me too", I have also experienced this. However, it's only on the Linux instance I run as a VirtualBox virtual machine on Windows. My two dedicated Linux installs have no problems. It is intermittent, but usually a problem within a week of the last restart. Restarting Emacs always fixes it for awhile. For @Drew: if I'm in a long running session, will starting with emacs -Q interfere with the operation? It's not easily reproducible. – Michael Johnson Jul 1 '16 at 14:42
  • @MichaelJohnson: I don't understand the question. But from other comments it sounds like it won't be easy to repro this. – Drew Jul 1 '16 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.