2

I have been interested in Emacs for a while, since I have seen some great articles on the Internet, which demonstrates the usage of Emacs as a C/C++ IDE. Those projects are awesome, yet they are not easy to be implemented by a novice Emacs user. I got problems with whichever of them I tried to implement. I searched the Internet a lot and a lot to solve my problems. One of my problems was solved accidentally by a coincidence, it was related to ELPA. After that new problems came out. I am really stuck right now. I want to use cmake-ide package (here) or cpputils-cmake package (here). Could you demonstrate how to use them assuming I only have Emacs and those packages from MELPA installed, or provide some resources to know learn which are prerequisite for using them?

note1: I am using "GNU Emacs 24.5.1" on ArchLinux.

note2: I could have installed those packages. My problems start afterwards.

  • 2
    Please clarify what steps you took, and where you ran into problems. The actual error messages would be good, too. If you can provide more precise information, it will help people to help you. – Dan Jul 1 '16 at 18:13
  • Configuring Emacs without some lisp knowledge can get really frustrating. Call me lame, but what helped me a lot configuring was learning a little bit of lisp. Also "Mastering Emacs" was very helpful. – jue Jun 27 '17 at 9:11
1

Both packages are available in melpa. You can follow instructions on how to add this repo:

(require 'package) ;; You might already have this line
(add-to-list 'package-archives
         '("melpa" . "https://melpa.org/packages/"))
(when (< emacs-major-version 24)
  ;; For important compatibility libraries like cl-lib
  (add-to-list 'package-archives '("gnu" . "http://elpa.gnu.org/packages/")))
(package-initialize) ;; You might already have this line

then, you can M-x list-packages and select them for installation.

FOLLOWUP:type Altx, then install-packages RET, select the packages with i, then execute the installation with x. See here for more info

  • Yes, I could have added MELPA, and installed the package. But I couldn't do afterward. – jnbrq -Canberk Sönmez Jul 1 '16 at 16:31
  • see my latest edit. Hope it helps – Felipe Lema Jul 1 '16 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.