3

i know there are other posts out there but i couldnt find an answer to this. is there anyway with latest org (8.3) to add additional symbols to the org-emphasis-alist? i tried for example adding the ! symbol but i cant seem to get it to work

(setq org-emphasis-alist (quote (("!"  (:foreground "red") )
             ("/" italic "<i>" "</i>") 
             ("_" underline "<span style=\"text-decoration:underline;\">" "</span>")
             ("-" (:overline t) "<span style=\"text-decoration:overline;\">" "</span>")
             ("=" org-code "<code>" "</code>" verbatim)
             ("*" org-verbatim "<code>" "</code>" verbatim) 
            ("+" (:strike-through t) "<del>" "</del>"))))

any clue?

alternatively, maybe another approach is to use perhaps the font-lock like this which i use now:

(font-lock-add-keywords
 'org-mode
'(("\\(@[^@\n]+@\\)" (0 '(:foreground "#B40000" :background "#FFDDDD" :weight bold) t))))

yet is there a way to hide the start-end symbols like in org-hide-emphasis-markers option?

2

Make sure you've restarted Emacs. The docstring for org-emphasis-alist says:

You need to reload Org or to restart Emacs after customizing this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.