I have found on google these 2 config options:

(gnus-demon-add-handler 'gnus-demon-scan-mail 3 t)
(gnus-demon-add-handler 'gnus-demon-scan-news 2 t) 

As far as i know this should auto check and refresh the group view with new mails? yet this rarely work (i say rarely since occasionally it does work for some reason..)

am i doing things wrong? is there any other way to check why this isnt working?

1 Answer 1


What you have configured here is that Gnus will check mail every three minutes but only if emacs is idle. Thus, if mail check time has come but you are typing, the check is skipped.

See the Gnus docs.

Note that this is still a good configuration given that emacs is single-threaded and thus checking mail will make emacs block.

  • ok i now have: ```(gnus-demon-add-handler 'gnus-demon-scan-mail nil 2) (gnus-demon-add-handler 'gnus-demon-scan-news nil 2)``. but still it wont update. is my code now right?
    – zeltak
    Commented Jul 15, 2016 at 9:09
  • Now it will check mail when emacs has been idle for two minutes. I guess you want the first number to be 2 and the last to be nil. Commented Jul 15, 2016 at 10:18
  • so i tried this:(gnus-demon-add-handler 'gnus-demon-scan-mail 2 nil ) (gnus-demon-add-handler 'gnus-demon-scan-news 2 nil ) still no auto checking (at least i dont think it does since the view dosent refresh and i dont see anything in the messages buffer. any clue what else to check? also even in idle it dosent refresh
    – zeltak
    Commented Jul 15, 2016 at 11:49
  • I just tried it, and it works for me. To allow for easier checking if it works, you can also set the timesteps to seconds instead of minutes. For example, I've tried (setq gnus-demon-timestep 1) (gnus-demon-add-handler 'gnus-demon-scan-news 5 nil) which will check news every 5 seconds even when emacs is not idle. BTW, gnus-demon-scan-news actually checks news and mail, so you don't need the other one. Commented Jul 15, 2016 at 20:00
  • so this is interesting. if i eval the command after emacs/gnus is loaded this works!...but if its in my config (init) then it dosent seem to work. any clue how one debuggs this?
    – zeltak
    Commented Jul 16, 2016 at 4:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.