1

When I try to install ac-cider via package-install or via init.el I get the message http://melpa-stable.milkbox.net/packages/popup-20160531.425.el: Not Found:

popup-20160531.425.el: Not Found

This is the code in my init.el:

(require 'package)
;; (add-to-list 'package-archives
;;              '("marmalade" . "http://marmalade-repo.org/packages/") t)
;; (add-to-list 'package-archives
;;              '("tromey" . "http://tromey.com/elpa/") t)
;; (add-to-list 'package-archives
;;              '("melpa" . "http://melpa.milkbox.net/packages/") t)

(setq package-archives '(("gnu" . "http://elpa.gnu.org/packages/")
                         ("marmalade" . "http://marmalade-repo.org/packages/")
                         ("melpa" . "http://melpa-stable.milkbox.net/packages/")))


;; Load and activate emacs packages. Do this first so that the
;; packages are loaded before you start trying to modify them.
;; This also sets the load path.
(package-initialize)

;; Download the ELPA archive description if needed.
;; This informs Emacs about the latest versions of all packages, and
;; makes them available for download.
(when (not package-archive-contents)
  (package-refresh-contents))

;; The packages you want installed. You can also install these
;; manually with M-x package-install
;; Add in your own as you wish:
(defvar my-packages
  '(ac-cider))

How can this be fixed so that ac-cider is installed?

  • Do you see any Messages about failing to download an archive? – John Kitchin Jul 13 '16 at 21:16
  • @JohnKitchin No. Just the message that popup is not found (and therefore fails to download). – Erwin Rooijakkers Jul 13 '16 at 21:23
  • I tried version 0.2.3 from melpa and it installed fine this morning. Please recheck and try the latest version. . . . . Compiling file /Users/HOME/.emacs.d/elpa/popup-0.5.3/popup.el at Wed Jul 20 07:58:46 2016 . . . . – lawlist Jul 20 '16 at 15:02
  • @lawlist Thank you. I will do so at home and will let you know the result. – Erwin Rooijakkers Jul 20 '16 at 16:01
  • @lawlist I checked and I still get the error: File error: http://melpa-stable.milkbox.net/packages/popup-20160531.425.el, Not found. ` – Erwin Rooijakkers Jul 21 '16 at 7:28
1
+100

It seems that your package archive metadata is corrupted. Try renaming your .emacs.d temporally and re-run with your init.el.

mv ~/.emacs.d ~/.emacs.d-tmp; emacs -Q -l path/to/init.el

I can setup successfully with your init.el pasted above (replacing last defvar with package-install).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.