7

I'm running emacs on Linux with HiDPI display and all X environment I successfully tuned to support it, but in emacs wavy underlines are still looking extremely thin (relatively to font size).

emacs thin wavy underline

I've checked face settings, but it allows only to customize color and style (wavy or line) of underlines.

Are there any other options that controlling width/size of underlines?

2
  • Which face have you identified as being applied? And what package applied it? flycheck? – Phil Hudson Jul 27 '16 at 21:08
  • 1
    See Emacs bug/enhancement request #26958, which asks for a wavy underline to text-scale along with the text. – Drew May 17 '17 at 4:17
2

The underwave is drawn at a fixed size and position. The relevant source code is at http://git.savannah.gnu.org/cgit/emacs.git/tree/src/xterm.c#n3381 and http://git.savannah.gnu.org/cgit/emacs.git/tree/src/w32term.c#n309. I don't see any reason why you couldn't fix that, though. You could scale the wave based on s->font->underline_thickness, for instance.

1

If wavy underlines are barely visible on a HiDPI display, consider upgrading to Emacs 26 as this issue has been fixed there. (I tried Emacs 26.3 specifically.)

0

Assuming you want to modify the flycheck-error face, and assuming you are using the Customize interface to do it, then note the "Show All Attributes" link just below the "Color" and "Style" settings. Clicking that will allow you to set any attributes you want, like maybe a different background color. The extra attributes won't enable you to thicken the underline specifically, though; I'm sorry, but I have no idea how that might be achieved. Hope this helps somewhat anyway.

1
  • 1
    Yep, I'm using flycheck, but this doesn't matter, because face settings is common type in emacs, so all packages have same set of attributes for it. Before posting this question I've read official docs and examined all attributes, but there's no such customization. Thank you for suggestion, but seems emacs at the moment doesn't support this. – stunpix Jul 28 '16 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.