0

this is a weird issue regarding Bookmark+. after an emacs restart the bmkp-jump-dired/bmkp-jump-1 functions wont work (when I launch them via a command such as in a hydra) before visiting the buffers.

This is what i see in my message buffer:

Loaded /home/zeltak/.emacs.d/settings.el
For information about GNU Emacs and the GNU system, type C-h C-a.
Invalid face reference: quote [24 times]
bmkp-jump-1: No bookmark specified

anyone else has this issues or know what causes this?

1

Do they work without using your hydra? If so, the hydra is likely where your problem is. Please try to provide a step-by-step recipe to reproduce the problem, starting with emacs -Q, using a simple bookmark file (even with just one bookmark), and saying what you expect to see at each step and what you do see instead.

The error raised from bmkp-jump-1 says that it was not given a bookmark to jump to. That suggests that the code invoking it (or invoking a Bookmark+ function that calls it) might be to blame - perhaps your hydra.

And the first error message (from where?), which is repeated 24 times (!) suggests that some code (that expected a face) was instead passed a quoted face symbol instead of a face symbol (after evaluation). This suggests that the quoted face symbol was either inside a list (e.g. (some list 'my-face)) or that it was used in a macro call (macros do not evaluate their arguments). (Does your hydra perhaps have 24 heads?)

Please show some code.

  • sorry for the late response @drew (..life got in the way..). so i dont think its a hydra issue. i loaded a new emacs..and tried to EVAL (bmkp-dired-jump "o.food" ) and i still get the same error. i also tried EVALING (bookmark-jump "o.grants" ) with the same results. – zeltak Nov 4 '16 at 9:36
  • Im a bit confused on the emacs -Q way to report back. should i launch emacs -Q, then load bookmark+, then eval the bookmark-jump with old bookmark file? should i backup old file and create new one? would you mind helping out on the steps needed? – zeltak Nov 4 '16 at 9:38
  • ok another observation: again if i launch emacs EVALING (bmkp-dired-jump "o.food" ) wont work and give the error BUT launching M-x bookmark-jump and choosing the o.food bookmark works well. is that a clue? – zeltak Nov 4 '16 at 10:36
  • To debug this, please send email offline: M-x customize-group bookmark-plus and click Send Bug Report. Provide a step-by-step recipe, starting with emacs -Q. That means emacs -Q, load Bookmark+, provide a simple bookmark file (e.g. with a single bookmark), list the keys you press etc. to repro the problem. If you need to load some other code to repro the problem, include that in your steps. Thx. – Drew Nov 4 '16 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.