From the Emacs Eclim github page:

Install emacs-eclim. You have two options:

  • Installation from the MELPA package archive.

    Just add the archive to package-archives if you haven't already, and

    then install emacs-eclim with the package-install command.

  • Manual installation from GitHub.

    (git clone git://github.com/senny/emacs-eclim.git)

    Add (add-to-list 'load-path "/path/to/emacs-eclim/") to your startup script.

If followed the first option and:

  1. Added the following package-archives to my ~/.emacs.d/init.el file:

    (setq package-archives '(("gnu" . "http://elpa.gnu.org/packages/")
                             ("marmalade" . "http://marmalade-repo.org/packages/")
                             ("melpa" . "http://melpa.milkbox.net/packages/")))
    
  2. Then typed M-xpackage-install and hit RET and the following message poped up:

    Install package: emacs-eclim [No Match]


Why does this error pop up?

Thanks in advance.

up vote 11 down vote accepted

Maybe refreshing package contents could help: try evaluating (package-refresh-contents) or typing M-xpackage-refresh-contents.

  • How to do evaluating (package-refresh-contents)? – Tim Oct 23 '14 at 13:44
  • 1
    Just type (package-refresh-contents) in the *scratch* buffer and, after the closing bracket, hit C-j. – Boccaperta-IT Oct 23 '14 at 13:47
  • 1
    The default binding for evaluating is C-x C-e. – Kaushal Modi Oct 23 '14 at 14:16

Just wanted to add my experience. I installed Emacs on my Mac via Homebrew and couldn't get it to find or list any packages from repositories other than the standard GNU ELPA, despite adding MELPA and MELPA Stable to my package-archives in my init.el (similar to above), and despite doing package-refresh-contents, restarting Emacs, rebooting my machine, etc.

I noticed status messages about using TLS as it was loading list-packages (although they all appeared to be successful), and checked my Homebrew Emacs install -- I hadn't installed with the with-gnutls option. I uninstalled Emacs and reinstalled, this time using with-gnutls, and this fixed the problem for me. So, for me, something like:

brew install emacs --with-cocoa --with-gnutls
  • 1
    It turns out (perhaps unsurprisingly) that TLS is only required if you use the "https" version of the repository URL's, e.g., if you use ("melpa" . "https://melpa.org/packages/") you need TLS, but if you use ("melpa" . "http://melpa.org/packages/"), which also works, you don't. – Jason Evans Jul 9 '17 at 12:23

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.