I am editing org-mode files with a lot of source code blocks. These blocks contain my own pseudo code that looks like this:

(A) {B} (C) 
(D) {F} (Z)

When moving within these blocks there is a pause or delay of several seconds between movements. After that the error message eldoc error: (error Variable binding depth exceeds max-specpdl-size)is displayed. First I thought the recent 25.1.1 update of railwaycat's Emacs for Mac was the culprit. But after a downgrade to the latest 24 version, the issue is still there. I then tried to rollback any package updates (with Spacemacs). Alas, to no avail. What can I do?

  • The default value of max-specpdl-size was 1300. I first set it to 2000 and then to 3000. The issue remains. – Singulaere Entitaet Jul 30 '16 at 8:07
  • I disabled eldoc globally using (global-eldoc-mode -1) which resolves the issue, but there is probably a more elegant solution required for users that rely on its functionality. Therefore I don't close the question yet. – Singulaere Entitaet Jul 30 '16 at 8:17
  • M-x toggle-debug-on-error and paste the backtrace here. Or just report a bug with M-x report-emacs-bug and attach the backtrace. – wasamasa Jul 30 '16 at 10:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.