1

I am using js2-mode as well as electric-pair-mode and autocomplete.

When I create a function using function () { and press enter the second curly brace is made on the next line but my cursor is placed on the same line, right next to it. I wind up with something that looks like:

function test () {
*} 

Where my cursor is where the * is. I am used to behavior that would leave it like this:

function test () {
   *<-cursor here
} 

Is there a way to re-enable that?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.