11

screenshot with an example I tried to add Noto Color Emoji from Google Noto as my font for Emoji in GNU Emacs, as mentioned in here, but for some reason GNU Emacs doesn't display these characters properly in its window. I'm using GNU Emacs 24.5.1 on GNU/Linux. Is this a bug or am I doing something wrong?

11

You're not doing anything wrong.

Emacs for Linux uses XFT for font rendering, and XFT doesn't yet support the color fonts. See this mailing list thread from Dec 2015. Richard Stallman writes in that thread that it's a low priority and they don't care about color fonts. Also in that thread you can see that they disabled color fonts in Emacs for Mac, not for any technical reason but because color fonts are not supported in the Unix version of Emacs and they don't want the Mac version to have a feature that is not in the Unix version.

So I wouldn't expect to see this any time soon.

| improve this answer | |
  • 5
    Actually, the feature is available in some development builds: ...* Changes in Emacs 27.1 ... ** Multicolor fonts such as "Noto Color Emoji" can be displayed on Emacs configured with Cairo drawing and linked with cairo >= 1.16.0. ... – Stefan Jun 1 '19 at 12:09
  • That's great to hear! – amitp Aug 28 at 16:32
3

Or you can use Emacs terminal (emacs -nw) on a terminal emulator that support color emoji.

Edit: Emacs can be run as GUI or terminal application. To start emacs terminal, open your terminal emulator (iTerm or iTerm2 in MacOS, Mate-Terminal or Gnaome-Terminal in Linux) and run the command emacs -nw in the terminal emulator. When running in terminal mode, the glyphs and fonts are not in control of Emacs and it must display what the terminal emulator is giving. With a terminal that support color emojis, you can force Emacs terminal to display them.

enter image description here

| improve this answer | |
  • Can you elaborate on your answer? – user12563 Jun 1 '19 at 11:57
0

Color emojis work with the noto color emoji and other emoji fonts in emacs 28

I tried to use emojis in the terminal on emacs 26 but it was glitched when I scrolled up and down. That was fixed when I upgrade as well

Now I am using GNU Emacs 28.0.50

| improve this answer | |
  • Please specify the Emacs release or prerelease info for the build you're using. Just "2020" doesn't mean much. – Drew Apr 25 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy