3

I have spent several days trying to debug auto-complete, it is working properly in Elisp mode, but when I go in Ruby mode it stops working. auto-complete-mode runs successfully, but the menu of candidates does not appear when I type the word or invoke the command auto-complete.

I installed auto-complete using package.el from melpa. I have not added any settings to my .emacs file.

What should I do to identify the bug?

I'm using Emacs 24.3.

  • What do you mean "is not working"? Is it turned off, or just not functioning? Can you start it with M-x auto-complete-mode? If yes, you can add hook for ruby-mode: (add-hook 'ruby-mode-hook #'auto-complete-mode) Warning: the code above is untested. – MatthewRock Oct 25 '14 at 14:46
  • can you edit your question with your .emacs file. – Vivian Maya Nov 3 '14 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.