0

I have a question about the babel latex package (not org-babel, which allows source code in documents).

I need to load the babel package with the american language set so I added:

#+LATEX_HEADER: \usepackage[american]{babel}

to my org file. However, in the tex export it adds english to this so that the tex output has:

\usepackage[american, english]{babel}

which I don't want. How can I fix this?

Thanks in advance!

3

Apparently, if you include the babel package with the brackets for package options, the org exporter adds as the value of the current language as an option for the package. So you can just set the LANGUAGE option as in

#+LANGUAGE: en-us
#+LATEX_HEADER: \usepackage[]{babel}

or

#+LANGUAGE: en-us
#+LATEX_HEADER: \usepackage[american]{babel}

The mapping between LANGUAGE code and babel option is given in variable org-latex-babel-language-alist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.