2

I recently installed a programming package, "Haskell mode," and apparently I changed how "initial parenthesis highlighting" works. I'm used to a quick black/white box superimposed on the initial parenthesis. Now there is a solid colored box that lingers for a while. How do I change this back to the default behavior?

  • May be it enabled show-paren-mode. Try (show-paren-mode -1) – nitishch Aug 9 '16 at 9:37
3

The original behaviour you describe sounds like blink-matching-paren:

blink-matching-paren is a variable defined in simple.el.

Non-nil means show matching open-paren when close-paren is inserted. If t, highlight the paren. If `jump', move cursor to its position.

The new behaviour you are seeing sounds like show-paren-mode. From the help for that function:

Show Paren mode is a global minor mode. When enabled, any matching parenthesis is highlighted in show-paren-style after show-paren-delay seconds of Emacs idle time.

As @nitishch commented, you can turn off show-paren-mode with (show-paren-mode -1). You can customize the behaviour of blink-matching-paren via M-x customize-variable blink-matching-paren. You can customize show-paren-mode via M-x customize-group paren-showing - this allows you to set the delay before showing parens, and the faces (fonts) used to highlight them.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.