I'm having to use Emacs on a few odd machines lately, and I've encountered the same annoying issue on all of them. Note that I'm using emacs-nox or the equivalent on every system. When I open a file from the command line, Emacs consistently hangs on the scratch buffer for 4-6 seconds before proceeding to the file. This occurs even when running Emacs as a daemon and opening files using emacsclient; the only way I can avoid it is to suspend Emacs with C-z, open it again with %emacs, and then C-x C-f for the file I want. The problem crops up on my Android phone (Termux), on Bash for Windows, and over SSH on two servers, running Arch and Ubuntu. I've tried a few solutions, some my own and others from reddit:

  • Deleting my .emacs and .emacs.d
  • Adding my hostname to /etc/hosts
  • Removing various hooks via .emacs
  • Compiling from source

So far, no dice. If anyone knows how to fix this, I'll love you forever; I'm almost at the point of switching to vim - almost.

  • Do you see it even with emacs -Q (no init file)? If not, recursively bisect your init file to narrow the problem. – Drew Aug 20 '16 at 2:32
  • @Drew Yeah, it still happens with emacs -Q. Even if I delete my .emacs and .emacs.d entirely, it still doesn't go away. – FitzWM Aug 20 '16 at 13:53
  • In that case, please try to post a step-by-step recipe to reproduce it from emacs -Q. And please consider submitting that as a bug report: M-x report-emacs-bug. – Drew Aug 20 '16 at 17:03
  • That's what I'm saying. If I do emacs-Q test.txt, for exampe, it hangs for a few seconds at the scratch buffer before proceeding. No further steps are necessary. I am sending in that bug report, though. – FitzWM Aug 21 '16 at 20:16

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.