1

Is there a way to bypass a prompt (set the value to nil) in an org-capture template with helm?

Specifically, template looks like this:

("m" "Meeting notes" entry (file "~/Dropbox/org/meetings.org")
       "* %^{Meeting Time}T %^{Title} %^g \n** %i%?\n " :prepend t)

How can I leave out the title (%^{Title}) or tags (%^g)? I've tried an empty string, but that aborts the capture. Pressing enter without any input selects the first helm completion.

  • 1
    In helm's mode-line, you should be able to see C/M-RET:Empty. – xuchunyang Aug 24 '16 at 11:33
2

C-ENTER seems to work for me when in the template substitution helm, which helm binds to helm-cr-empty-string in the helm interface.

(There's probably a better way of discovering this, but I just did it via trial and error having tried various other unsuccessful things such as C-u ENTER, M-ENTER and a simple ..)

  • For me it was actually M-RET that worked (on a mac with spacemacs), though I couldn't confirm what function it's bound to. How did you discover helm was binding to helm-cr-empty-string? When I run describe-function (spacemacs SPC h d f) it doesn't show any bindings : \ – Jay Aug 24 '16 at 17:57
  • Glad that's helped. I think it'll be in the mode-specific bindings, so it'll only be bound when the helm interface is actually showing. I can see that binding with C-h k C-ENTER when the helm interface is popped up (describe-key). – Stuart Hickinbottom Aug 24 '16 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.