I thought that org-mode highlighted source blocks with the relevant mode. So for example:

#+BEGIN_SRC clojure
(defn plus [a b]
  (+ a b))

This would show up with the syntax highlighting one would expect if in a Clojure buffer.

For some reason, my setup is just showing the above example in one monotone of gray.

1 Answer 1


Org-mode fontifies these blocks if you enable the corresponding setting. Try:

(setq org-src-fontify-natively t)
  • Thanks. I must've lost this setting when switching machines. Oct 27, 2014 at 0:22
  • does not work for me
    – avp
    Dec 11, 2018 at 9:47
  • Feel free to open a new question for your specific problem.
    – wasamasa
    Dec 11, 2018 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.