0

When I type M-s-h emacs reports: M-s-˙ is undefined

That tiny dot is the 'DOT ABOVE' (U+02D9) character.

I'm on OS X. This is happening when I use the emacs-plus build. With emacs-mac port I don't see this behavior.

Is there any way for me to debug this?

  • 1
    How are your modifier keys set up? I'm guessing that Alt is meta, and Command is super, is that right? Then the problem is likely that Alt-h is DOT ABOVE. How to work around that, I don't know, but the documentation for emacs-plus (which I don't use) ought to tell. – Harald Hanche-Olsen Sep 1 '16 at 16:33
  • @HaraldHanche-Olsen You nailed it. It is indeed Alt-h sending DOT ABOVE. – ivan Sep 1 '16 at 20:32
1

This might be a problem because some part of this keystroke is interpreted as that letter. Try typing it (like you did in Emacs and using other modifiers) in some other text editor or another thing where you can type in using your input methods, and check your keyboard settings.

I would comment this, but the reputation system here is pretty bad, and I can't even help people if I wanted to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.