0

I have tried several setups and I just can't seem to be able to get anaconda and yasnippet working at the same time (dabbrev would be nice as well). First I tried reorganizing the order, it was a suggestion somewhere. If one puts anaconda higher(first) than yasnippet, then anaconda will show in the dropdown and yasnippet won't be listed in the dropdown (yas-expand works though).

This is my current order:

(company-anaconda company-bbdb company-nxml company-css company-eclim
  company-semantic company-clang company-xcode company-cmake company-capf
  company-files (company-dabbrev-code company-gtags company-etags company-keywords
                 company-web-html company-yasnippet) company-oddmuse)

If I place company-anaconda below(after) company-oddmuse, then yasnippet works, but anaconda does not.

Also tried something like this, to have it specifically working under python-mode, also does not work:

(add-hook 'python-mode-hook (lambda ()
              (set (make-local-variable 'company-backends) '(company-anaconda :with company-yasnippet))
                      (company-mode t)))

Or

(add-hook 'python-mode-hook (lambda ()
              (set (make-local-variable 'company-backends) '(company-anaconda company-yasnippet))
                      (company-mode t)))

In the above cases changing the order also does not make a difference. Anyone having problems with this as well?

0

Ok It seems that I have found an answer myself. Here it is for anybody wanting it as well:

(add-hook 'python-mode-hook (lambda () (set (make-local-variable 'company-backends) '((company-anaconda company-dabbrev-code company-yasnippet)))))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.