1

I have had the issue that emacs will lock up (and need to be force quit) on occasion when I minimize it. I am almost always in org-mode, but otherwise I can see any pattern, except that it happens while it is minimized.

I have scoured the world for a fix to this. Does anyone know how to fix this, or at least how to figure out why it is happening?

I'm on OSX 10.11 with Emacs 24.5

  • Where did you get your 24.5? Did you get it from the tried and true generic build all packaged into one nice and neat Emacs.app from emacsformacosx.com ? Did you build it yourself? Did you use homebrew or macports? Have you tried another build from a different source to see if your problem magically goes away? If you are using homebrew or macports, perhaps you are accessing other components that might not be present in the most generic build from emacsformacosx.com For example, if Emacs sees available ingredients when building from source, they will become a part. – lawlist Sep 15 '16 at 1:09
  • Of course, most everyone here will want to know if you have tried with a minimal Emacs user-configuration -- i.e., as close as you can get to emacs -q as possible. If you have tried everything else and want to assist the Emacs team to debug the issue, you can build from Emacs source and then launch Emacs under gdb from the Terminal.app and then get a backtrace when it locks up. In such a case, you would leave the source files where they are while debugging. You might also want to try playing with the Emacs 25 release candidate, or the master branch build. – lawlist Sep 15 '16 at 1:18
  • 1
    Note that Emacs 25 and later (e.g., master branch) have several important bug fixes relating to frames, including sizes and placement. The only time I fire up 24.5 for OSX is when I'm trying to answer a question for someone on an Emacs forum. – lawlist Sep 15 '16 at 1:23
  • @lawlist thanks! I had used EmacsForOSX, I am not trying a brew solution, but that is still 24.5. If that fails I will try 25-rc2. Thanks. If any of these work, I will create a solution to my own issue. (If you want to create that solution ticket for me then, I can also accept yours.) either way. thanks! – Dan Oblinger Sep 16 '16 at 18:13
2

I have been using the ``not yet stable'' 25-rc2 build of Emacs for a month without any lockup issues. So it seems @lawless is correct, and this did fix the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.