3

In my .emacs file, I have (global-prettify-symbols-mode), and if I visit a .el document, I see the lambda character instead of lambda.

My understanding is that in a .tex file I should see the beta character instead of \beta, but this does not seem to work. The auctex manual says that if global prettify symbols mode is enabled, then this should work automatically.

Any ideas of what could be going wrong?

  • Is prettify-symbols-mode enabled in your .tex file? – caisah Sep 19 '16 at 19:22
  • Yes, it is. And I've tried disabling it and then re-enabling it. – Alex Sep 19 '16 at 19:22
  • Are you using Emacs 25? Apparently there were problems in 24 with prettify lists.gnu.org/archive/html/auctex/2016-03/msg00040.html – caisah Sep 19 '16 at 19:40
  • Yes, on Arch Linux (if it makes a difference) – Alex Sep 19 '16 at 20:38
  • I've just checked and you are right. When I disable and re-enable prettify-symbols-mode in my LaTeX buffer, the prettification works. Strangely, with the dev version of GNU AUCTeX, the prettification is there immediately when finding a new TeX file. But there are no changes at all wrt prettification between 11.89.5 and the dev version. Not sure what's the problem... – Tassilo Horn Oct 13 '16 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.